OpenStreetMap

P symbol appearing in building instead of parking

Posted by Sanderd17 on 23 October 2010 in English (English)

Hi,

I have a concave parking:

http://www.openstreetmap.org/?lat=50.840695&lon=3.114961&zoom=18&layers=M

As you see, the P is appearing in the building. I know I could split the parking in 2 pieces and so there would be 2 parking symbols. But I always heard not to change the data for the purpose of rendering.

Should I show this to someone who's working on mapnik?
Should I adapt the data (split the parking)?
Or should I just leave it?

Greets,
Sander

Btw: is there a new server? The updating of the map was freaking fast.

Location: Kasteelstraat, Dadizele, Moorslede, Roeselare, West Flanders, Flanders, 8890, Belgium

Comment from Vclaw on 23 October 2010 at 17:51

This is a fairly common problem in Mapnik, so I think its been reported a few times before. Mapnik always renders the symbol or name in the middle point of the area. But for complicated shapes, this sometimes means the symbol is outside the area.

See for example these reports on trac (not for parking, but its the same cause):
http://trac.openstreetmap.org/ticket/2306
http://trac.openstreetmap.org/ticket/2295

I don't know if these will actually be fixed any time soon.

Hide this comment

Comment from derKuchen on 24 October 2010 at 08:45

Yes, there is new hardware in the servers, I don't know any details, maybe you find something via the wiki Main_Page :)

Hide this comment

Comment from Sanderd17 on 24 October 2010 at 09:00

Ok, I guess I'll just leave it that way.

And about the servers: I didn't find anything more recent than 25 august:
http://wiki.openstreetmap.org/w/index.php?title=Servers/Upgrades&action=history

Hide this comment

Leave a comment

Parsed with Markdown

  • Headings

    # Heading
    ## Subheading

  • Unordered list

    * First item
    * Second item

  • Ordered list

    1. First item
    2. Second item

  • Link

    [Text](URL)
  • Image

    ![Alt text](URL)

Login to leave a comment