OpenStreetMap

New edits not showing (yet again)

Posted by GMHeyes on 1 March 2017 in English (English)

The area I now live in is a bit short of detail, I enjoyed editing around my previous address, so last night I thought I would start adding features around my new home. the aim is to start locally and then moving around my home town! I made half a dozen or so edits, which included shops, a path, removed a road that no longer exists, grassed areas and terraced housing. None of the above is yet to appear on the map, I have checked on my iPad, PC and mobile phone. I used the id (In browser editor)

Location: Moorside, Oldham, Greater Manchester, North West England, England, OL4 2XA, United Kingdom

Comment from Autarch on 1 March 2017 at 23:05

Hi, I noticed the same thing with some edits I made to Howth in Dublin last night. I noticed a couple of things: *My edits from last night appear in the Humanitarian layer of OSM (house names don't, but that's probably down to the layer). *Query feature (right click, then fifth item on menu) will bring up a list of items on the left - clicking on the item highlights it in orange on the map, even if it's not rendered under usual circumstances. I can see some houses from last nights edits that way.

Hopefully you can find your edits using the above techniques. (The editor I used was JOSM.)

Comment from GMHeyes on 1 March 2017 at 23:27

Hello, thanks for your reply, is it just me or does adding features and generally trying to improve the map, not just for our benefit but for everyone else's as well - seem a bit too much like hard work most of the time? I registered 5 years ago, and have edited before but last night was the first time I've edited in a while, and here I am again asking questions as to why nothing has appeared!

Comment from BushmanK on 1 March 2017 at 23:41

Everything is totally okay with your edits if you have them saved. However, Standard style map is not the main product of OSM, so you shouldn't be worrying about this particular product. Regarding of checking your edits, it is better to turn on Data layer on osm.org (blue contours will appear as an overlay) and click on object outlines you are concerned about. There could be many reasons for this situation, from cached images in your browser to delays in rendering queue due to some massive edits elsewhere. Again, a bottom line is: you shouldn't be worrying.

Comment from SomeoneElse on 2 March 2017 at 15:02

It's a known problem - there's just been a discusson on IRC about it.

Comment from GMHeyes on 2 March 2017 at 21:01

Thank you I have just read that discussion, I would presume once the error has been rectified then all the edits will at some point re-appear? So I'll carry on editing as normal.

Comment from SomeoneElse on 3 March 2017 at 09:47

Yes - just to reiterate what has been said above - your edits are fine, and anyone using OSM data will see them. All the mobile apps that use OSM data will include them at the next upgrade cycle. The various third parties using data from e.g. Mapbox will see them; even the public transport infrastructure and the company printing maps that are displayed near supermarkets and railway stations local to me will see them too. They'll appear on the "standard" map at osm.org too, just a little slower for now.

Comment from GMHeyes on 3 March 2017 at 09:53

Thank you for clearing that up!

Comment from Dalkeith on 6 March 2017 at 10:51

Yes there is sometimes a short delay - but its not in the editing layer so I never over edit my previous stuff. After a period its rock solid from my viewpoint as well

Login to leave a comment