OpenStreetMap

Frustrations with photo mapping

Posted by daveemtb on 12 May 2009 in English (English)

I haven't done any photo mapping for a long time, but took some photos on a recent journey, planning to fill in some street names by referencing to the GPX.

Unfortunately I can't seem to get Agpifoj working. The documentation on the wiki doesn't cover the essentials, and I get stupid erros claiming that none of the photos match. I tried to reinstall the plugin, but now my JOSM installation has got totally messed up. I tried clearing out the .JOSM folder (i'm on a mac now) and downloading the JOSM .jar file again, but now it comes up with a blank list of plugins. :( I can install the plugin manually by placing the jar file in the .JOSM folder but it still doesn't work, even with no other plugins.

The times in the GPX file match up perfectly with the timestamps on the photos.

This is doing my head in! :(

Anyone got any suggestions?

I say bring back the old geotagged photo plugin! :(

Comment from Paul Johnson on 12 May 2009 at 20:34

Just to be clear: Wikipedia is the name of one specific wiki, but is not all wikis.

Your photos must have EXIF tags, IIRC...

Hide this comment

Comment from Guillaume Audirac on 13 May 2009 at 05:55

Some time ago, I had an issue with AgPifoJ and I raised a ticket on the JOSM bug tracker (http://josm.openstreetmap.de/ticket/2124). After raising, I had contacted developers involved in this plugin. I suggest you to do the same and to contact:
- Christian Gallioz: christian.gallioz (at) wanadoo.fr
- Stefan Breunig: stefan (at) mathphys.fsk.uni-heidelberg.de

They could help you.

A reminder: the timezone has to be set to GMT+0 wherever you live, as the GPX and the EXIF times are usually already synchronized.

Hide this comment

Comment from daveemtb on 13 May 2009 at 06:05

Thanks Paul, was a typo - fingers to used to typing wikipedia! Have fixed that now.

Guillaume, thanks, the problem is, I just don't know if I'm doing it right because the documentation doesn't cover the buttons and options properly :( I definitely had the timezone as zero. What units is the offset box in? is it hours or seconds?

Hide this comment

Comment from daveemtb on 13 May 2009 at 06:06

PS, Paul, yep, the photos definitely have EXIF tags.

Hide this comment

Comment from CiaránMooney on 13 May 2009 at 12:40

The units for the offset is dd/mm/yy hh:mm:ss I think.

Hide this comment

Comment from mdecker on 13 May 2009 at 18:55

i'm not really sure if JOSM will do the lookups for you. i used gpscorrelate to put gps info into my pictures. after that it loads perfectly in JOSM

Hide this comment

Comment from smsm1 on 16 May 2009 at 05:15

I usually have to try a few different timezone options to get my traces to work properly.

Hide this comment

Leave a comment

Parsed with Markdown

  • Headings

    # Heading
    ## Subheading

  • Unordered list

    * First item
    * Second item

  • Ordered list

    1. First item
    2. Second item

  • Link

    [Text](URL)
  • Image

    ![Alt text](URL)

Login to leave a comment